IDN Forums - Internationalized Domain Names  
Home | Advertise on idnforums | Premium Membership

Go Back   IDN Forums - Internationalized Domain Names > IDN Discussions > General Discussion

General Discussion Feel free to talk about anything and everything in this board.

Reply
 
LinkBack Thread Tools Display Modes
  #1 (permalink)  
Old 18th September 2007, 07:37 AM
Junior Member
 
Join Date: Oct 2006
Posts: 90
iTrader: (0)
Rep Power: 507
charley is an unknown quantity at this point
Question Give me a solution to this

Why do I get ?? instead of the unicode and is there a solution for it ? The unicode works correctly in MS Word, but others show ??? .
Reply With Quote
  #2 (permalink)  
Old 18th September 2007, 08:28 AM
Member
 
Join Date: May 2007
Location: Hong Kong / China
Posts: 864
iTrader: (3)
Rep Power: 575
Asiaplay is an unknown quantity at this point
Re: Give me a solution to this

Hi Charley - what "others" are you referring to?

It is most likely as the others are only using "ascii" encoding and not unicode format - this is why you see squares or ???.
Please describe what other software you are having trouble with and maybe we can help.

Cheers - Asiaplay
Reply With Quote
  #3 (permalink)  
Old 19th September 2007, 10:54 AM
Junior Member
 
Join Date: Oct 2006
Posts: 90
iTrader: (0)
Rep Power: 507
charley is an unknown quantity at this point
Re: Give me a solution to this

Quote:
Originally Posted by Asiaplay
Hi Charley - what "others" are you referring to?

It is most likely as the others are only using "ascii" encoding and not unicode format - this is why you see squares or ???.
Please describe what other software you are having trouble with and maybe we can help.

Cheers - Asiaplay
Thanks for the reply.

Other programs that show ?? instead of the squares are WordPad, Notepad, Outlook Express[sending emails].
Reply With Quote
  #4 (permalink)  
Old 19th September 2007, 12:51 PM
mulligan's Avatar
Senior Member
 
Join Date: Jan 2006
Posts: 4,254
iTrader: (78)
Rep Power: 2055
mulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enough
Re: Give me a solution to this

Control Panel >> Regional and Language Options >> Click on the 'Languages' tab >> Check the box that says 'Install files for complex script and right-to-left languages (Including Thai) and also check the box that says 'Install files for East Asian languages) >> Click 'OK' and follow the instructions.

You will need your original operating system CD (XP or whatever windows OS you are using) to install the files from.

Or get yourself a Mac ..
Reply With Quote
  #5 (permalink)  
Old 19th September 2007, 04:06 PM
Member
 
Join Date: May 2007
Location: Hong Kong / China
Posts: 864
iTrader: (3)
Rep Power: 575
Asiaplay is an unknown quantity at this point
Re: Give me a solution to this

Charley,

Try what Mulligan suggests first... this should fix it (if you do not have these languages installed yet).... as with MS Word & MSExcel having this issue (most likely you have not installed the language packs for MS Windows yet).

The problem otherwise is either missing fonts (unusual scripts) or the file you are viewing is not in "Unicode" format - it is relying on Character Sets like Big5 GB etc. (so try changing the font manually to see if you can view the characters).

Note that files which are ascii based (notepad is by default) can not read non-latin character sets and you need to therefore use Unicode file types (In notepade Save As andi choose at bottom - Unicode or UTF-8 rather than ascii).

Also try to work in Unicode where you can (for MS Word & Excel this is Unicode-16) - for the Web it is Unicode-8.
For my own work I have also downloaded various Unicode fonts - search on the web for these (there are a lot of free ones for Windows).

Cheers - Asiaplay

PS: if still having issues after doing this - the please let us know or feel free to PM me...
Reply With Quote
  #6 (permalink)  
Old 25th September 2007, 09:18 AM
Junior Member
 
Join Date: Oct 2006
Posts: 90
iTrader: (0)
Rep Power: 507
charley is an unknown quantity at this point
Talking Re: Give me a solution to this

Quote:
Originally Posted by mulligan
Control Panel >> Regional and Language Options >> Click on the 'Languages' tab >> Check the box that says 'Install files for complex script and right-to-left languages (Including Thai) and also check the box that says 'Install files for East Asian languages) >> Click 'OK' and follow the instructions.
Mulligan,

Thanks for the reply.

I am running Win98 Se. The language setting doesn't appear there.

Any help will be welcome.
Reply With Quote
  #7 (permalink)  
Old 25th September 2007, 01:28 PM
Member
 
Join Date: May 2007
Location: Hong Kong / China
Posts: 864
iTrader: (3)
Rep Power: 575
Asiaplay is an unknown quantity at this point
Re: Give me a solution to this

Hi Again,

You are still using Windows 98... opps (now we know why!)

You either need to either run a "Chinese" version of "MS Windows" (not English etc.) OR you need to use an add-on software so you can see and/or type Chinese, Korean and Japanese (Unicode fonts or Language Specific fonts).

There used to be many add-on software available - i.e. NJStar, RichWin, Chinastar etc. - however appears only NJStar is still doing this software.

Consider using NJWIN - NJStar CJK Viewer 1.92 (if just want to view) or NJStar Communicator 2.70 (if also want to type) see http://www.njstar.com/

Really maybe the best approach... would be to upgrade to Windows XP - as it makes viewing all texts (all languages) much easier.

Cheers - Asiaplay

PS: Also in addition the free fonts from Twinbridge might be helpful later (free if you say you are a student from memory I think ) - see CHINESE UNICODE TRUETYPE FONTS (http://twinbridge.com/DownloadCH.aspx)
Reply With Quote
  #8 (permalink)  
Old 25th September 2007, 03:49 PM
xxbossmanxx's Avatar
Member
 
Join Date: Dec 2006
Location: Detroit
Posts: 429
iTrader: (6)
Rep Power: 0
xxbossmanxx is an unknown quantity at this point
Send a message via AIM to xxbossmanxx Send a message via MSN to xxbossmanxx Send a message via Skype™ to xxbossmanxx
Re: Give me a solution to this

Windows 98! Houston, we have a promblem
__________________
I Build sites like this for cash and IDN's.
http://www.rarecom.com/
Reply With Quote
  #9 (permalink)  
Old 25th September 2007, 03:59 PM
mulligan's Avatar
Senior Member
 
Join Date: Jan 2006
Posts: 4,254
iTrader: (78)
Rep Power: 2055
mulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enoughmulligan will become famous soon enough
Re: Give me a solution to this

Charley,

Upgrade your operating system to Windows XP (Home or Professional ~ whatever's within your budget)
It should install over the top of Windows 98 with minimal fuss.
There's tons of XP operating systems on ebay an you should be able to pick it up for cheap.

Check it out here:
http://computers.search.ebay.com/win...4QQsacatZ11226

Make sure you buy one with a certificate of authenticity and not an illegal copy
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 04:16 AM.

Site Sponsors
Your ad here
buy t-shirt
מחיר הזהב

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Search Engine Friendly URLs by vBSEO 3.3.0
Copyright idnforums.com 2005

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54