View Single Post
  #7 (permalink)  
Old 12th August 2006, 06:06 PM
domainguru's Avatar
domainguru domainguru is offline
Senior Member
 
Join Date: Mar 2006
Posts: 3,835
iTrader: (14)
Rep Power: 2567
domainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura aboutdomainguru has a spectacular aura about
Re: IDN Site building

Quote:
Originally Posted by seamo
Haven't found which is better yet, but only similar problem I have with SuperEdi as with Textpad.

Different options are available for Japanese encoding, but I cannot paste Japanese straight into document. it is returned as 'llllll'

Any ideas why domainguru?
It's mainly a matter of matching encodings. When you paste text into a program, the program doesn't "know" what encoding it is. So the program should be set to be the same encoding as the text you are pasting in. Then, theoretically, and if you have the correct fonts installed for the encoding, everything should be ok.

There may also be issues caused by "copying/pasting" messing around with the characters i.e. the clipboard might attempt to "interpret" the characters (wrongly) and hence mess around when it shouldn't be doing.

Like bramiozo suggests, the best way to work is in a standard format i.e. UTF-8. That way, you can store and display text in all languages stored in the Unicode standard.

This is a great intro to Unicode / text encoding (thanks Jase)

http://www.joelonsoftware.com/articles/Unicode.html
Reply With Quote